Cisco – Switchboard modules for routers 28xx and 29xx

How to access a router switchboard module ?

There are several switchboard modules available for example:

  • SM-ES3-16-P
  • SM-ES2-16-P
  • NME-X-23ES-1G

How does a switchboard module works ?

A switchboard module is a fully functional switch with its own IOS and it own configuration. The interconnect between the router and the switchboard is a logical interface that is not visible in hardware. But has to be configured.

When the switchboard is attached to the router and the router is powered up the following command will shoe its presents:

MYROUTER#sh inventory
NAME: "CISCO2921/K9 chassis", DESCR: "CISCO2921/K9 chassis"
PID: CISCO2921/K9      , VID: V07 , SN: XXXXXXXXXXX

NAME: "SM-ES3-16-P: EtherSwitch SM L3 + PoE + 15 10/100 + 1 10/100/1000 on Slot 1", DESCR: "SM-ES3-16-P: EtherSwitch SM L3 + PoE + 15 10/100 + 1 10/100/1000"
PID: SM-ES3-16-P       , VID: V02 , SN: XXXXXXXXXXX

NAME: "C2921/C2951 AC Power Supply", DESCR: "C2921/C2951 AC Power Supply"
PID: PWR-2921-51-AC    , VID: V03 , SN: XXXXXXXXXXX

Further you can see the new logical interfaces that has been created depending on the slot you use. In my case a GigabitEthernet 1/0 has been created:

MYROUTER#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
Embedded-Service-Engine0/0 unassigned      YES manual administratively down down
GigabitEthernet0/0         10.10.89.38    YES NVRAM  up                    up
GigabitEthernet0/1         10.20.89.113   YES NVRAM  up                    up
GigabitEthernet0/2         unassigned      YES NVRAM  administratively down down
GigabitEthernet1/0         unassigned     YES NVRAM  administratively down down 
GigabitEthernet1/1         unassigned      YES unset  up                    down
Loopback0                  10.250.254.8     YES NVRAM  up                    up
Vlan1                      unassigned      YES unset  down                  down

How to access the switchboard ? No serial or USB Available ?

Well this can be managed internally via the router:

First assign an IP to GigabitEthernet1/0 and enable it:

MYROUTER# conf t
MYROUTER (config)#int gi 1/0
MYROUTER (config-if)#desc ** Virtual trunk to Switch **
MYROUTER (config-if)#ip address 10.0.0.1 255.255.255.252
MYROUTER (config-if)#no shutdown
MYROUTER (config-if)#end
MYROUTER#

Now you are able to access the switchboard:

MYROUTER#service-module gigabitEthernet 1/0 session

Now you will realise that a new setup dialog will ask you for auto configuration. Well of course “NO” is the only answer to theses wizards.

Than “switch>” will appear. Et voila you have entered the switch module and it is ready to be configured.

to exit the switch module you must remember the following command:

CRTL+ALT+6 x

Now you are back on the router, but as soon as you hit Enter you are back on the switch board. This is kind of annoying. But when you have entered the router via the shortcut enter: “disconnect” and the session to the switchboard module will close.

When you telnet / ssh session to the router crashes the connection is still connected and you will net be able to reconnect to the switchboard. Either you reboot the router, which does not make sense you can use the following command:

MYROUTER#service-module gigabitEthernet 1/0 session clear

And reconnect to the switch board module.

What needs to be done to get VLANS and routing on the switchboard ?

Therefore the logical interface exists and additional sub interface can be created on the router itself (duoble check the configuration that has been done before):

MYROUTER#show interface GigabitEthernet1/0
 description ** Virtual trunk to Switch **
 ip address 10.0.0.1 255.255.255.252
end

To get access to a specific VLAN a subinterface is needed:

a VLAN sub interface on the router for VLAN 2:

MYROUTER#sh run int gi 1/0.2
Building configuration...

Current configuration : 201 bytes
!
interface GigabitEthernet1/0.2
 description ** Client network **
 encapsulation dot1Q 2
 ip address 192.168.25.254 255.255.255.0
!

The counterpart for the logical interface on the router on a SM-ES3-16-P and SM-ES2-16-P is GigabitEthernet 0/18. This port need to be setup as a trunk port for the VLAN that should be allowed. (example for VLAN 2)

interface GigabitEthernet0/18
 description ** Virtual trunk to Router **
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 2
 switchport mode trunk
 switchport nonegotiate
 mls qos trust dscp

If more VLANs are needed more sub interfaces have to be setup and the trunk need to be allowed to transport more than just vlan 2.

All that is missing now is taht the ports on the switchboard will be part of VLAN 2:

interface range FastEthernet0/1 -16
 switchport access vlan 2
 switchport mode access

Now all devices that will be connected will be part of VLAN2 and be able to [ping the gateway (int gi 1/0.2)

3 comments for “Cisco – Switchboard modules for routers 28xx and 29xx

  1. Tarul
    July 24, 2014 at 02:54

    we have 2911 router with SM-ES2-16-P module. It comes up with Gi1/0 and Gi1/1 interface on router. I’ve figured out finally that you’ve to give IP address to gi1/0 and no shut to get to switch. What I don’t get is what other interface is for. Under description of that interface you get its internal iterface for switch. Can you share some light on it?

    • December 16, 2015 at 22:17

      yeah the Cisco docs aren’t great if you can’t actually get your hands on them. I’d say your gi1/0 is your virtual dot1q trunk back to the switch

      • phil
        January 28, 2016 at 09:09

        I am not hundret percent shure that is is virtual but it Comes with the switchboard module. I still find it kind of tricky 🙂

Leave a Reply

Your email address will not be published. Required fields are marked *